请选择 进入手机版 | 继续访问电脑版

站长赚钱网赚钱论坛

 找回密码
 立即注册
查看: 130|回复: 3

[站长交流论坛] php5apache2.dll不能加载 [Apache 与 PHP整合问题]

[复制链接]

41

主题

110

帖子

381

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
381
发表于 2018-7-8 08:43:56 | 显示全部楼层 |阅读模式
现象:
加入下面两行,apache就不能启动的问题
LoadModule php5_module modules/php5apache2.dll
AddType application/x-httpd-php .php

回复

使用道具 举报

41

主题

110

帖子

381

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
381
 楼主| 发表于 2018-7-8 08:44:03 | 显示全部楼层
原因:
由于apache版本的不同,对应的 "php5apache2.dll" 也不同

LoadModule php5_module modules/php5apache2.dll这段代码的配置应该修改为
LoadModule php5_module modules/php5apache2_2.dll
回复

使用道具 举报

41

主题

110

帖子

381

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
381
 楼主| 发表于 2018-7-8 08:44:09 | 显示全部楼层
因为你使用的apache是2.2版本的。
LoadModule php5_module "c:/php/php5apache2_2.dll"
AddType application/x-httpd-php .php
回复

使用道具 举报

41

主题

110

帖子

381

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
381
 楼主| 发表于 2018-7-8 08:44:14 | 显示全部楼层

总结:
Apache2.2 对应 php5apache2_2.dll
Apache2.1 对应 php5apache2.dll
Apache1    对应 php5apache.dll

由于上述原因,假设是安装了 Apache2.2 又安装了 PHP5.0那就要出错了。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|Archiver|手机版|小黑屋|站长赚钱网赚钱论坛 ( 皖ICP备13004459号 )

GMT+8, 2018-8-16 22:14 , Processed in 0.143369 second(s), 22 queries .

Powered by 冯站长之家 Discuz! X3.4

© 2001-2017 冯站长之家论坛

快速回复 返回顶部 返回列表